
MailScan Installation Guide 

       
 

1 
 

 

 

IMAGE ARCHITECTS, INC. 
 

 

 

MailScan Installation Guide 

 

Release 1.1 

 
 

 

 

 

 

Headquarters 
248 West 35th Street, 7th  Floor 
New York, New York 10001 
Telephone:      (212)  967-2780 
Facsimile:        (253) 369-6107 
Internet:  www.imagearch.com 

 
 

The information furnished in this schema is proprietary to Image Architects, Inc. and, therefore, is 
privileged and confidential.  It shall not be disclosed outside the organization for any reason without 
the prior written approval of Image Architects Inc., or duplicated, used or disclosed in whole or in part, 
for any purpose other than to evaluate the contents.  This restriction does not limit your right to use 
data contained in such information if obtained from any other source without restriction. 



MailScan Installation Guide 

       
 

2 
 

Table of Contents 
 

1 INTRODUCTION ................................................................................................................................ 3 
1.1 WHAT'S INCLUDED IN THIS PACKAGE .............................................................................................. 3 
1.2 PREREQUISITES ............................................................................................................................... 3 
1.3 A NOTE ABOUT LICENSING AND OUR EVALUATION PACKAGE ........................................................ 3 

2 INSTALLING THE PERSONAL BARCODE PRINTER ............................................................... 3 

3 INSTALLING THE MAILSCAN SOFTWARE ............................................................................... 4 
3.1 STEP 1 – LOAD THE SOFTWARE ON YOUR PC .................................................................................. 4 

3.1.1 From CD................................................................................................................................. 4 
3.1.2 From a Digital File................................................................................................................. 4 

3.2 STEP 2 – CONFIGURE ASCENT CAPTURE 5.X ................................................................................... 4 
3.2.1 Add the MailScan Release Script............................................................................................ 4 
3.2.2 Import the MailScan Batch Classes........................................................................................ 5 
3.2.3 Customize the MailScan Release Script.................................................................................. 7 
3.2.4 Publish the MailScan Classes............................................................................................... 11 

3.3 STEP 3 - CONFIGURING THE EMAIL/BARCODE CONNECTION......................................................... 12 
3.3.1 Configure the Personal Barcode Printer.............................................................................. 12 
3.3.2 Configure your Email Connection........................................................................................ 12 
3.3.3 Configuring Your DSN: (For ODBC Database selection only)............................................ 14 
3.3.4 Configure Avery Label Sheets .............................................................................................. 16 

4 USING MAILSCAN........................................................................................................................... 17 
 



MailScan Installation Guide 

       
 

3 
 

1 INTRODUCTION 
This guide tells you everything you need to install the MailScan software programs.  Please note that 
scanner installations vary from manufacturer to manufacturer so you should consult the instructions 
that came with your scanner. 

1.1 What's Included in this package 
Your MailScan software package includes several programs/pieces that will be installed.  These 
pieces are: 

1. MailScan Barcode Printing  

2. MailScan Release Script for Kofax Ascent Capture 5.0 

3. MailScan Documentation 

4. Personal Barcode Label Printer 

1.2 Prerequisites 
The following two programs must be installed prior to installing MailScan: 

1. Email client such as Outlook or Lotus Notes 

2. Kofax Ascent Capture 5.x with installed scanner 

1.3 A Note about Licensing and our Evaluation Package 
MailScan is available for free download from our website and other locations.  To purchase a license 
key to MailScan, please contact Peter Nirenberg at Image Architects: 212-967-2780 or by email: 
pnirnenberg@imagearch.com. Until you decide that MailScan is right for you and your company, you 
can use MailScan as much as you want without per-page limitations.  Assuming you have a Kofax 
scanning system already in place, the shareware copy will allow you to perform a complete 
demonstration, from printing barcode stickers on your own printer, to emailing the documents through 
your existing email system.   

9 Please note: Without the license key, all documents that are emailed through the MailScan 
system will be watermarked, and only 2 rows of barcode labels will be printed at a time.  

2 INSTALLING THE PERSONAL BARCODE PRINTER 
The barcode printer that comes with MailScan uses its own native installation process, however the 
MailScan system uses a custom module to print barcodes to this printer. Please see the document on 
Barcode Printer Setup and Installation. Be sure to remember if you have selected a USB or Serial 
connection for that process. 
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3 INSTALLING THE MAILSCAN SOFTWARE 

3.1 Step 1 – Load the software on your PC 

3.1.1 From CD 
1. Place the CD in your CDRom drive. 

2. Using Windows Explorer, browse to your CD Rom drive and run the program setup.exe. 

3. Follow the onscreen instructions. Install the components to a temp directory such as 
c:\Temp\mailscan.   

4. Once it is finished, go to Step 2 – Configure Ascent Capture 5.x. 

3.1.2 From a Digital File 
If you obtained the program through FTP or in an email, follow the directions below: 

1. Unzip the file to a temp directory 

2. Run c:\temp\setup.exe 

3. Follow the onscreen instructions 

3.2 Step 2 – Configure Ascent Capture 5.x 

3.2.1 Add the MailScan Release Script 
1. Start the Ascent Capture Administration Program 

2. Click Tools>Release Scripts 

3. On this new Dialog box, click Add 

 
4. Enter/browse to the location of the MailScan Release Script: 
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c:\Program Files\MailScan\IAMailScanRelScript.inf 
 

 
5. Click Open. 

6. In the next window, make sure to highlight the name of the script in the box before 
clicking the Install button. 
 

 
7. When it is finished installing, you will get a notification that registration is complete.  Click 

OK on this notication box. Click Close on the Add Release Scripts box and on the 
Release Script Manager box. 

3.2.2 Import the MailScan Batch Classes 
1. From the main Ascent Capture Administration window, Click File>Import 
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2. Enter/browse to the location of the MailScan CAB (.cab) file. Open it. 
 

 
3. A new window will appear that shows you the progress of the file unpacking.  When it is 

finished, click the OK button located at the bottom of the 

window.  

4. Select both batch classes from the Available Batch Classes box by clicking Add All.  
Leave the Transfer Mode radio buttons at the bottom of the window as their defaults. 
Click the Import button.  They will then start to import, and you will see the progress in a 
new window.  

5. When they have finished importing, the last line of the progress box will read 
“Completed”. Click OK and you will notice that the two batch classes now appear in the 
main Administrator window. 
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3.2.3 Customize the MailScan Release Script 
Follow these steps for each batch class you import.  If you imported both MailScanPDF and 
MailScanTIF batch classes, you will need to repeat this process for both. 

1. Right Click on the document level of one of the Batch Classes you just imported, and 
select Release Scripts… and you will see the following window: 
 

 
2. Select the IA MailScan Release Script from the box at the right, and click the Add >> 

button.  The name will then appear on the left.  

3. Click the Setup button.  You will then see the following window: 
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Index fields used for indexing appear on the first Index Storage Tab (samples are shown 
above).  Any values that will be needed for indexing should be configured here. You can 
add more if you wish to do so.  When you are finished, click the Document Storage tab. 
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4.  From the Document Storage tab, select the document image type from the dropdown 

box. This above sample batch class is meant for PDF documents, so the PDF selection is 
made. 

5.  Next, under Store Image: select how you would like the image to be delivered to the 
recipient.   Your options are: 

a) as an attachment within the mail message – meaning that tiff or pdf files will 
be attached to your email. Keep in mind that this method will make emails large 
and may not be the optimum choice for some situations. 

b) to a file server (with a hyperlink in the mail message) – meaning that all files 
will be stored on a shared directory, and the recipient will receive an email with a 
hyperlink to that shared directory instead of an attachment.  If you select this 
option, follow the steps below: 

i. In the Release Directory field, enter/browse to the remote directory 
location where you would like the image files to be stored. 

ii. The Hyperlink Base URL field indicates to the system how you would like 
the link to the document to be.  This is the link that will appear to the user 
in their email. 

iii. Now proceed to the email settings tab and continue with step 6 below. 
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c) In IBM OnDemand (with a hyperlink in the mail message) – meaning that you 
can use IBM OnDemand/Content Manager to help manage your documents. If 
you select this option, you will need to enter some additional information.  Please 
fill in the following fields: 

i. Release Directory field, enter/browse to the remote directory location 
where you would like the image files to be stored. 

The storage structure is set up like this: 
<Release Dir>\<recipient's 
emailaddress>\<mmddyyyy>\<imagefile.ext> 

Example 1: if <Release dir> = c:\emails, then the string will look like this: 
 

 
c:\emails\jgiancaspro@imagearch.com\11292001\3961006
9019281.pdf 

 
Example 2: if <Release dir> = \\yoshi\marketing\emails, then the string will 
look like this: 

 
\\yoshi\marketing\emails\jgiancaspro@imagearch.com\1
1292001\39610069019281.tif 

 
9 Please Note: The above strings (including the potential 

filenames, which will not appear when you are setting up the 
locations) cannot exceed 255 characters in length.  Batches will 
not release properly, and you will get errors if the limit is 
exceeded.  Be sure to take this limit into consideration, including 
the date and filename portions. 

 
ii. Hyperlink Base URL field is the link that will appear to the user in their 

email.  It indicates to the system how you would like to link to the 
document.  <Hypherlink base URL> allows for the ability to specify the 
"file:" protocol. It also allows one to specify a web page.  The string 
should be set up like this: 

<Hyperlink base URL>\<recipient's email address>\<imagefile.ext> 
 
Example 1: if <Hyperlink base URL> = file:c:\emails then the string would 
look like this: 
 

file:c:\emails\jgiancaspro@imagearch.com\11292001\
39610069019281.pdf 

 
 

9 Please Note: If you are using a shared directory for your image location, you will 
need to make sure that all pieces involved (Content Manager/OnDemand, 
MailServer, client and scanning workstations, etc) have access to the directory. 
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6. Next, click on the Email Settings tab.   
 

 
 

7. From this tab, you can customize the text that will appear in the email accompanying your 
attachment or database link.  

 

8. Next, enter the profile name of the email server you will be using to send the mail. 

 

9. In the Image Attachment Options section select the method you want to send mail to 
recipients.  If you select Insert Hyperlink, you must enter the URL information so that the 
database link works when the user clicks on it. When you are finished, click OK. 

 

10. Click Close on the Release Script Manager window. 

 

11. Repeat the above steps for any additional batch classes you imported. 

 

3.2.4 Publish the MailScan Classes 
1. Click on the MailScan Batch Class 
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2. Highlight the Batch Class and use File>Publish 

3. From the Publish window, select the batch from the list, and clicking the Publish button.   

9 Please note that you will get a warning when you publish these classes.  This is 
perfectly OK.  Ascent Capture normally expects a validation or recognition module in 
your queues but MailScan doesn't require them.   

4. Repeat steps 2 and 3 for other batch classes you imported.  When they are finished 
importing, click OK. 

5. You can now begin scanning your mail.  

3.3 Step 3 - Configuring the Email/Barcode Connection 
The first time you open the MailScan program, you will need to configure it so that it can use the 
contact list from your existing email program. 

3.3.1 Configure the Personal Barcode Printer 
1. Open the MailScan Program 

2. Click Tools>Setup 

3. On the Smart Label Printer Settings tab Click the radio button that applies to your 
printer’s location.  The location you selected when installing the native barcode software 
should be the same selection made here. 
 

 

3.3.2 Configure your Email Connection 
1. Click on the Email Settings tab 
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2. From the drop down box, select the database you would like to use.  Depending on which 
database you would like to use, you will see different options appear upon selection.   

 
If you selected Outlook Contacts or Lotus Notes Contacts, you are done with this tab, and 
should proceed to section 3.3.4 Configuring the Label Sheet Settings. 

If you selected ODBC Database, you will need to make sure have configured the DSN (Data 
Source Name) so that the MailScan software can retrieve the contacts properly.  See section 
3.3.3 Configuring Your DSN below for details. 
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3.3.3 Configuring Your DSN: (For ODBC Database selection only) 
1. From the Start Menu, click Settings>Control Panel 

 
2. Double click on ODBC Data Sources (32bit). From the new window that appears, click 

the second tab labeled System DSN.  You will then see a window that looks similar to 
this: 

 
3. Click the Add button.  You will now see a new window from which you can select your 

new Data Source.  It will look similar to this: 
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4. Select the type of database you would like the MailScan program to read from.  (A 

Microsoft Access database is selected in the example above.)  Click Finish. 

5. Depending on the type of database selected, you will see a different window with different 
options.  With the wide variety of databases out there, they cannot all be explained here.  
Enter the information needed to set up your specified database type.  If there are any 
problems, contact your system administrator. 

6. When you have finished, you will then see the newly created Data Source in the list as 
shown below with the example Microsoft Access database called emailcontacts. 

 
7. Click OK. 
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8. Now open or return to your IA Barcode Printer Settings screen, and on the Email Settings 
tab, select ODBC Database from the dropdown box.  

 
9. In the first field, enter the name of the Data Source Name you just created. 

10. If your database requires a login, enter the username and password in the next two 
fields. 

11. Next, enter the Database table name.   

12. Now enter the name of the field where MailSafe should pull the value of the contact name 
and email address. 

13. If you would like the program to remember your password so that you do not have to log 
in each time you start up MailSafe, then check the box beside Save Password.  If not, 
leave it blank.  You will be prompted for a password next time you open the program. 

14.  Click OK.  You are now done setting up your Email Settings and your Database 
connection.   

3.3.4 Configure Avery Label Sheets 
1. Click on the Label Sheet Settings tab 

2. Select the label format that you intend to use.  The settings of standard Avery labels will 
appear in the dropdown box for your convenience.  
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3. When you are finished, click OK. 

4 USING MAILSCAN 
Now that you’ve installed and configured MailScan you can start using it. 

Please refer to the MailScanUserGuide document that is included in the MailScan package. 

 


